INSTALLATION OF ALEPH GUI IN A CUNY LIBRARY               	EXPIRATION DATE:  07/01/2020

PREPARATION STEPS

[bookmark: _GoBack](1) Check the above EXPIRATION DATE on this document and, when needed, retrieve an updated version from the OLS Support Site: https://ols-support.cuny.edu/?q=systems/aleph 
    
(2) For a PC’s first install of any Aleph GUI: 
(a) Java Virtual Machine is required. Download and install the latest version: https://www.java.com/en/download/
(b) Set a Windows default printer for each user.
   
(3) Retrieve the latest Aleph GUI installation file named GUI500-Stage_062014.exe or GUI500_Prod_122014.exe from the OLS Support Site at    
                 https://ols-support.cuny.edu/?q=systems/aleph/client-installation    

(4) Please do NOT install STAGE on a Circulation Desk machine used student workers.
    
     Note: IF you previously completed step 24, skip to the last page of these instructions. 

(5) After saving old reports, remove previous Aleph directories, and C:\Aleph_Install. 

(6) For all PCs (especially for Circulation AND Acquisitions staff) there is a known antivirus issue: McAfee Antivirus can interfere with e-mails being sent by Aleph to patrons. McAfee Antivirus MUST be modified to allow exceptions. These are just three of the possible options, and the first does not require admin access:
     
(a) Open Aleph GUI application. Click on McAfee icon on the lower right Windows toolbar → select ‘McAfee Agent Status Monitor’ -> click on ‘Collect and Send Props’ 

(b) Place an exception in Access Protection under Prevent Mass Mailings Worms by adding three entries for the Aleph GUI client: Acq.exe, Catalog.exe, & Circ.exe.

(c) Simply turn off “Prevent mass mailing worms from sending mail” in McAfee Console → Access Protection → Anti-virus Standard Protection.  [ not recommended ]
      
ALEPH GUI CONFIGURATION STEPS

(7) Log in to PC as an Administrator and create a directory called C:\Aleph_Install
      If this directory already exists, then (delete old files) replace it with the latest version.

(8) Move GUI500_*.exe into this directory and double-click it. Right-click on setup.exe and choose ‘Run as administrator.’
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(9) Accept the defaults but CHANGE THE PATH EXACTLY TO C:\Aleph21Stage or C:\Aleph21Prod  when you reach the ‘Select Destination Directory’ step. (The install and all future support answers are based on using this path.)

[image: ]

(10) Enter any label you prefer for ‘Program Manager Group,’ which is where desktop icons will be added. Remove all extra Aleph icons; only keep Circ, Catalog, and/or Acq. (Please ask staff which they use and want on their desktop.) Otherwise please accept the defaults.
[image: ]

To give all users on a workstation access to the Aleph ‘Program Manager Group’ via the Start Menu, copy the ‘Program Manager Group’ to the following directory: C:\ProgramData\Microsoft\Windows\Start Menu\Programs  

Note: If the installation gets stalled on the ‘Install Fonts’ phase, please make note of the 
path shown in the prompt window. You can simply install these fonts by clicking on ‘InstallFonts’ as shown in the next image. You may prefer simply adding ‘Carolina’ barcode fonts.  

Also, re-booting the PC after install is not required at this step. (It is required before beginning to use Aleph.)
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(11) If you previously installed this version of Aleph 21, OVERLAY all directories and files from your flash-drive, and skip to the below Post Configuration steps (step 18).

(12) Look in the directory named C:\Aleph_Install\AL500\Aleph_21_ini for your campus’s files named xx_print.ini and xx_alephcom.ini, where ‘xx’ is your two letter campus code. 

Remove the ‘xx_’ prefix and overwrite the existing files in *\alephcom\tab\.  (‘* ‘ means  C:\Aleph21Stage or C:\Aleph21Prod.)




Please see the following example image:
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(13) Please do not modify alephcom.ini and print.ini files at this step. Changing these files may result in unexpected behavior in the Aleph GUI client.

Note: All Aleph GUI and Aleph server communication is encrypted. Changing settings to evade requiring a password for sign in poses a security risk.

(14) Create a directory named C:\Aleph21Stage\temp or C:\Aleph21Prod\temp
Confirm it matches what is listed in alephcom.ini for TempDir= .
[ Recommend: C:\Aleph21Prod\temp in case of copy to another PC ]

(15) For ALL Technical Services PC(s), review column 2 in:  
*\acq\tab\print.ini, 
*\alephcom\tab\print.ini,
*\catalog\tab\print.ini 

(‘* ‘ means  C:\Aleph21Stage or C:\Aleph21Prod.)

Use your library’s existing  settings in column 2 for your current version labels. (Column 1 function name will have the word ‘Label’ in it for any of the various different PC events that trigger labels to print.) These now all must go in *.\alephcom\tab\print.ini to work as expected.

Please see the following example image:
[image: ]


(16) Please check that this file has this setting:      C:\Aleph21Prod\Acq\tab\print.ini

ArrivalMessage                           00 N B arrmsg.prn
ClaimLetter                                 08 N M arrmsg.prn

Note: do not enter ‘tab’ characters; only spaces.

(17) For ALL Circ staff PC(s), review *\circ\tab\print.ini for columns 2, 3, and 4. 

DO NOT edit the lines for ReturnHold## or HoldLetter## (where ‘##’ are numbers), other than possibly changing column 2 to match what is listed in your Aleph 18 installation in .\circ\tab\print.ini. Making changes can result in your unintentionally disabling patrons from receiving CLICS notices.

Column 2 must be set to your VERSION for notices, if any (e.g., ‘09’ for Dymo receipt printer) 
Column 4 must be set to ‘B’ or ‘M’ for patrons to receive email notices

Note: Please DO NOT add any new lines to the ‘circ’ print.ini file. 

POST CONFIGURATION STEPS
(18) Change directory file permissions to allow staff to modify C:\Aleph21Stage and C:\Aleph21Prod.  Users and Aleph MUST have FULL read/write access.
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(19) For ALL Circ staff PC(s), please go to Options menu to set up loan and return options:
   
(a) Set Up LOAN Options: ‘Display Messages for Patron’s holds,’ ‘Display Item is requested,’ ‘Create Return Receipt,’ and ‘All loans on one receipt.’
  
(b) Set Up RETURN Options: ‘Print return receipt’ (unless you don’t use these), ‘Display List of Hold Requests’ (matters for CLICs), ‘Display Item is currently not on loan,’ and ‘At end of session with current patron.’
   
(c) Check Work Station Identifier (lower right hand corner – right click on the ‘yellow key’)
  
(d) Recommend: ‘Display Circulation Note’ (loan & return), ‘Display Loan Notes’ (return)
  
(e) Optional: Turn off Cash Receipts in *\circ\tab\circ.ini              [Payment]      CashNoReceipt=0 
  
(f) Optional: Turn on remote storage messages in *\circ\tab\circ.ini   [ReturnSession]   RemoteStoreMessage=Y 
  
(g) Recommended: Notify Staff when an item has an IPS which may be incorrect 
*\circ\tab\circ.ini    [General]   NotifyProcessStatus=Y       
                                                         DatesDefaultSubLibrary=<your main sub-library, eg KB001>
 (20) Select ‘Version Check’ from the Aleph drop down menu. We want to select type: sp_exe, and click on ‘Update All’ button. (This will be preparation for Service Pack Updates.)

(21) For Technical Services PCs, set sub-library and other filters. (order index, budgets) 
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(22) For all Technical Services staff PC(s), review *\acq\tab\acq.ini for the subscription date range check setting.

In the Acquisitions / Serials module, the invoice record has a check box labeled ‘Check subs date overlap’.  The default is ‘Y’ to automatically set the box as checked. Either accept the default, or switch it to ‘N’ for no (the box is ‘unchecked’).

The below change will allow for staff/patron notifications when orders are arrived.

*\acq\tab\acq.ini
[Invoice]
SubscriptionDateRangeCheck=Y 

[Arrival]
ArrivalMessages=Y 

Consult your Acquisitions / Serials staff for guidance on which is best for their workflow.

(23) Please make certain all Acquisitions and Circulation staff who send emails also have access to your library’s email server.

(24) If this is your first Aleph 21 install, copy all directories and files in C:\Aleph21Stage or C:\Aleph21Prod to a flash-drive (or storage device of your choice). Rename this restore point and re-save it AFTER any desired optional settings. (Also include the install file.)
Replace these two files with blank files: C:\*\Circ\files\CUN50\  loan.log & return.log. 
OPTIONAL SETTINGS

These changes are generally not required. However, for some of your library’s PCs these changes will be mandatory.

Please consider making as many of these changes as possible standard across your PCs, and include this in your master files (stored on a flash-drive). If you need to leave some functionality turned off, it is recommended to do so in the alephcom.ini.

‘* ‘ means  C:\Aleph21Stage or C:\Aleph21Prod.

(A) Automated Printing / Emailing

For the Circ desk PC that will automatically email patron notices ONLY, you will need to turn this on in the alephcom.ini file. 

Remove the ‘;’ symbol at the beginning of the line that you want to enable; add a ‘;’ symbol to the beginning of any line being replaced. Only keep one of each line active (without a ‘;’).

C:\Aleph21Prod\alephcom\tab\alephcom.ini

[PrintDaemon]
;Targets=[all valid Print ID options for your library are already listed if step 12 was completed]
;PrintdAutoActivate=Y
;PrintdAutoDeactivate=Y 
Targets=printer01
PrintdAutoActivate=N
PrintdAutoDeactivate=N

Note: For the “Target=”, please do not add new targets. The targets must match what Print IDs are on the server. Problems arise when people add unsupported Print IDs. 

Please open Task Manager and make certain that the ‘Setup Type’ = Mail and ‘Print Configuration’ = Print.

It is strongly recommended that you open Task Manager -> Print Daemon to select the desired Print IDs and make sure to click the “Activate” button in the right top corner. 

Please leave notices turned off on ‘Stage’.

 (B) UMD Printing – SUPPORT DISCONTINUED

UMD Print users (primarily in Technical Services) will need to double check the path setting which identify where UMD Print is installed. The below example shows the ‘EDIT’ and UMD specific ‘LABEL_PRINT’ being enabled for UMD Print.

Remove the ‘;’ symbol at the beginning of the line that you want to enable; add a ‘;’ symbol to the beginning of any line being replaced.

*\alephcom\tab\alephcom.ini
[PrintExecute]
ERROR_EDITOR=notepad.exe 
LABEL_PRINT=c:\umdprint\umdprint.exe $1
;EDIT=notepad.exe $1
EDIT=c:\umdprint\umdprint.exe $1
 [Print]
; Raw XML required for UMD Print
DefaultPrintConfig=2

Note: UMD Print path must be verified. Also, support has been discontinued for this open source solution. 

For more information on UMD Print, it is no longer available; this link has been discontinued: http://www.d.umn.edu/~kharriss/umdprinthome.html

(C) Default Printing Options

Change Default Printing option for staff:

*\alephcom\tab\alephcom.ini
[Print]
DefaultPrintConfig=#

The following table explains the three different values you can choose from:
	DefaultPrintConfig
	Staff Area
	Comments

	0
	Circulation
	Always use the only setting that permits emailing to patrons.

	1
	Tech Services
	Preview reports BEFORE printing

	2
	Label Making Staff
	Raw XML required for some printing solutions like UMD Print



(D) Changing Font Size
To increase or decrease font sizes in Aleph, the recommended method involves two steps.
The first step affects all programs, not only Aleph. Do not be too concerned about the Aleph fonts at this step; it is not the final adjustment. 

First, modify the font sizes in Windows by going to the Control Panel and opening Display. [Control Panel → Display] Choose between small, medium, or large. Restart Windows then open the ALEPH client and play around with re-sizing various windows in the different tabs. 

Only after adjusting your preferred general settings determine whether you need to make Aleph-specific adjustments. If needed, move to the following second step.

The second step is to modify as needed a file named *\alephcom\tab\font.ini  
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(a) Please make a copy of the file before you edit it so you have a version to which you can roll back.

(b) You will find lines in the file which look like this below line:

EditorTag  00000 0FFFF Courier  Y N N 16 DEFAULT_CHARSET

Increase the font sizes by a value of 2 (e.g., try increasing 16 in this column to 18). Restart Aleph to see the changes and adjust accordingly.

Note: Keep the value differences proportional when making changes.

(c) Under certain conditions, adjusting the numbers too high will prevent screen scrolling in the Aleph GUI. Proceed with caution.

(E) Change Background Colors in the GUI Screen
One simply method is to click the drop down menus in the GUI: ‘Aleph’ → Options → Customize. Select the ‘Main Tab Configuration’ tab and change the background color as instructed by the local manager.   
People who have both Staging and Production Aleph GUI installed might want a visual cue using background colors to highlight the Aleph version. (eg yellow on Staging and pink on Production).  This really makes it easy to keep track of the current environment.
 (F) Reverse the Right and Left Split Screen Editing Menu in Cataloging Module

A new configuration option has been added to allow you to define the hot keys for Catalog Record Edit menus. We have already reversed the default, yet you can set it back.

The cataloging module editor is divided into two menus. A user opens the Edit Text cataloging editor menu by right-clicking and the Edit Actions menu by pressing Shift while right-clicking. It is possible to reverse the hot keys for these menus. This is done by changing the Editor section in the catalog.ini file:

*\catalog\tab\catalog.ini
[Editor]
RightClickMenu=EditActions

Possible values for “RightClickMenu”:

· EditActions (default) – Right-click to activate the Edit Actions menu. Press Shift + right-click to activate the Edit Text menu.
· EditText – Right-click to activate the Edit Text menu. Press Shift + right-click to activate the Edit Actions menu.

(G)  Adding Bells and Whistles 

Brief and distinct sound alerts for Circulation events may be added. (eg return of lost books)

*\circ\tab\circ.ini
[ErrorAction]
     <GUI event> = Y,F, <wave file>

For example:  LostReturn=Y,F,notify.wav

Available sound files:

blip.wav          chimes.wav       ding. wav         newemail.wav    notify.wav         online.wav ringin.wav       type.wav            utopia1.wav    utopiaas.wav      utopiaex.wav   utopiaqu.wav    
xpbatcrt.wav   XPInfoBar.wav  xpLogon.wav   XPLogoff.wav


(H)  Preventing Bersoft popup page 

Disabling the Bersoft pop up page will override all settings in Aleph that prompt you to choose from a list of printers. Aleph print jobs will only be sent to the default printer for a PC.

The Bersoft pop up page does not harm printing. Turn it off with these settings only if you want to always print notices, or when choosing only to send emails. 
1. Open the Aleph installation directory on C:  (i.e. C:\Aleph21Prod\) 
2. Go to /alephcom/bin/ then open the file HTMLprint.ini in an ASCII text editor 
3. Change SetPrinter=1 to SetPrinter=0 
4. Use “Save As” to create and save a new ini file (i.e. HTMLprint2.ini) in the same directory 
5. Go to /alephcom/bin/ then open the Bersoft TMLprint utility (HTMLprint.exe) 
6. Go to File > Configuration File > Load - Select the HTMLPrint2.ini file then click Open 
7. Answer “YES” when asked "Do you want to use this configuration file as the default one?" 
NOTE: When logging into a Windows 10 workstation for the first time, use steps 5 to 7.

(I)  Configure DYMO Receipt Printing (Service Desk) 
    
Using this option will configure Aleph to apply these margins for all Aleph printing on this PC.
1. Install a Dymo printer and set its “Paper Size” to “Continuous, Wide”. 
2. Open the Aleph installation directory on C:  (i.e. C:\Aleph21Prod\) 
3. Go to /alephcom/bin/ then open the Bersoft HTMLprint utility (HTMLprint.exe) 
4. Go to File > Configuration File > Load - Select the HTMLPrint_Dymo_Reciept.ini file then click Open 
5. Answer “YES” when asked "Do you want to use this configuration file as the default one?" 
6. Exit out the Bersoft HTMLprint utility.
7. Go to /circ/tab and open the PRINT.ini file in an ASCII text editor and make sure that the rows for the Dymo Receipt printer are selected (uncommented).
8. Adjust settings in the [MARGIN] section of its HTMLPrint_Dymo_Reciept.ini ONLY if needed. These margin settings will apply to all other Aleph printing on that workstation.
Note: If you run into a problem with the installation, please log a work order with the CUNY Service Desk [service.desk@cuny.edu] and copy OLS so we can follow up immediately. You are welcome to give us a call.

(J) Use of Email Server Authentication
If your library will use a local SMTP server that requires authentication, you must contact OLS. There are two additional changes required. 

The first is in the alephcom.ini file.

C:\Aleph21Prod\alephcom\tab\alephcom.ini

[Mail]
Mailserver={SMTP mail server]
AuthMethod=LOGIN
;AuthMethod=

The second is open a work order ticket with OLS to request an encrypted file named “EMailPwd.dat”.  This file will be installed in C:\Aleph21Prod\Alephcom\tab\.

This file must be installed on all Aleph PCs, including  both Circulation and Acquisitions staff.

Aleph back office functions (Admin module -> Configuration -> E-Mail Settings) are used to create this file. You will need to supply OLS with the user name and password to be used. (We can exchange this information over the phone if you prefer to not have it in writing anyplace.)

(K) Aleph Floating Keyboard

Catalogers can have the copyright, registration and production symbol [ c, r, p with a circle] keys to the first tab of the cataloging keyboard.  These are the steps to make this change:
· Make a backup of this file: C:\Aleph21Prod\Alephcom\tab\keyboard.txt 
· In the [Latin Supplement] section only of this file replace the below lines:

Replace:
\00C0

With these new lines:
\00A9
\2117 
\00AE
\00C0
Quick Summary

(1) Check above EXPIRATION DATE on this document; as needed retrieve an updated copy 
   
(2) Retrieve latest Aleph GUI installation file download named GUI500_*.exe from the OLS Support Site (* means Stage or Prod), (or use your flash drive from step 24 above).

(3) For a PC’s first install of an Aleph GUI: Install the latest version of Java Virtual Machine and set a Windows default printer for each user.

(4) There is a known antivirus issue: McAfee Antivirus can interfere with e-mails.  (step 6)

(5) Using a PC Administrator account, move  GUI500_*.exe into a directory called C:\Aleph_Install  (If this directory already exists, replace it with the latest version.)

(6) Right-click on setup.exe and ‘Run as administrator’
   
(7) Accept the defaults but CHANGE the Destination PATH EXACTLY TO C:\Aleph21Stage or C:\Aleph21Prod (The install is based on this path.)

(8) Make sure you have a path: C:\Aleph21Prod\temp 

(9) If the installation gets stalled on the ‘Install Fonts’ phase, please make note of the path shown in the prompt window. Manually run the install fonts script.

(10) Using your flash-drive copy of your previously installed version of Aleph 21, OVERLAY all directories and files. (The detailed summary allowed you to build a quick install ‘file overlay’.)

(11) Change directory file permissions to allow staff FULL read/write access to C:\Aleph21Stage and C:\Aleph21Prod.  

(12) For ALL Circ staff PC(s), please go to Options menu to set up loan and return options

(a) Set Up LOAN Options: ‘Display Items on hold for this patron,’ ‘Display Item is requested,’ ‘Create Return Receipt,’ and ‘All loans on one receipt.

(b) Set Up RETURN Options: ‘Print return receipt’, ‘Display List of Hold Requests’, ‘Display Item is currently not on loan,’ and ‘At end of session with current patron.’

(c) Set the Work Station ID : Right-click the lower left hand image of a yellow ‘key’.

(13) Select ‘Version Check’ from the Aleph drop down menu. We want to select type: sp_exe, and click on the ‘Update All’ button. 

(14) See optional settings from full install instructions as needed [eg PC that emails patron notices set in alephcom.ini: ‘Targets=’, PrintdAutoActivate=Y, and ‘PrintdAutoDeactivate=Y ]
1
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